Watch now button doesn't work

Operating System Version:<Mac OS Catalina Version 10.15.5>

Popcorn Time Version:<0.4.4>

Download date:<Reinstalled it 11th June 2020>

Download url:

Up until recently, I clicked the watch now button for various films and tv shows and they worked fine. Suddenly clicking the watch now button does nothing. The watch trailer button still loads a trailer. I’ve tried to reinstall the app (clean re install having moved all the files from library first). I have flushed the database in popcorn time. I have changed ISP from Virgin to Vodafone. But i’ve turned the firewall off in my router settings. In my Mac settings the firewall allows popcorn time connections. Not sure what else I can do or if it’s a bug.

I saw this multiple times on this forum and I don’t know how it has been solved. But can you access the logs of PT?

Do you mean a screenshot of the console?

Actually I’ve managed to fix the issue. I downloaded the 422 build from Jenkins, but I also turned my content control off in Vodafone broadband settings. I think that was stopping it working. Thanks for your reply though!

I am having this same problem. It was working fine until yesterday and now the watch now button doesn’t work. I always use VLC so that isn’t the issue. I have reinstalled twice now-nothing. Any advice? So frustrating

same here. I uninstalled reinstalled it. it worked and then stopped again