PT 0.4.4 doesn't open any more on Ubuntu 18.04

Dear all, I have been using PT for several years and I find it amazing. Few days ago I opened it and I saw the black screen with the loading circles. At first I thought the database was down. After some days I uninstalled it and reinstalled but now it doesn’t even open any more.

Any idea/help about how to solve it? Thanks a lot in advance, warm regards :slight_smile:

I don’t know if you open it using the terminal. If not try to do it and send the output of the terminal.
I personally had the issue of the ‘infinite loading’ I solved it by running PT as root using sudo ./Popcorn-Time in the tarball archive. Ask me if you have question or want further support :slightly_smiling_face:

(edited) thanks a lot for your reply. Ehm…what exactly do you mean with tarball archive? The file .tar if I get it correct. How do you access that file as if it were a folder? I only have a .zip file. Sorry, I am not super skilled with Linux :slight_smile:

You’re right the tarball is the .tar file.

  1. Extract the file in folder
  2. Click right in the folder > Open in terminal
  3. Write : ./Popcorn-Time or sudo ./Popcorn-Time to run it as root
  4. Give the output of the command : )

so I extract the .zip file in a folder called popcorntime. I opened the folder in the terminal and I copy-pasted your command. that’s what I got

~/Downloads/popcorntime$ sudo ./Popcorn-Time
[sudo] password for ale:
[8446:8473:0424/120420.025799:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are “tcp” and on UNIX “unix”)

DevTools listening on ws://127.0.0.1:9222/devtools/browser/ecd54f98-5a59-4f30-8cd2-9902ff4452a0
[8469:8469:0424/120420.089955:ERROR:sandbox_linux.cc(376)] InitializeSandbox() called with multiple threads in process gpu-process.
[8487:8487:0424/120420.109609:FATAL:nw_content_renderer_hooks.cc(53)] Failed to load node library (error: libatomic.so.1: cannot open shared object file: No such file or directory)
#0 0x7f6e02b27db9

1 Like

I think the real problem is the :

I will look at it just after and post a new reply :slightly_smiling_face:

1 Like

thanks a lot man, I appreciate it. Talk to you later :slight_smile:

1 Like

Can you tried to search the package ‘libatomic1’. I don’t know if you use ‘synaptic’ as package manager, if so you can search for the package ‘libatomic1’. If not you can run the following command : sudo apt-get install libatomic1 && sudo apt-get -f install

Tell me if that works.

2 Likes

yeeeep, that was the problem :wink: thanks a lot man, it works again!!! a hug!!

1 Like

You’re welcome! If you have any problem feel free to contact me! Have a nice day! :smile:

1 Like

Hi everyone! I am having the same issue and tried to install libatomic1, it did not work for me. I am a rookie trying to learn, please tell me what I am not doing right.
When I try running PT from the terminal I get this:
DevTools listening on ws://127.0.0.1:9222/devtools/browser/531c152d-5174-4876-be56-c298a2409326
[3121:3121:0501/002255.237925:ERROR:sandbox_linux.cc(376)] InitializeSandbox() called with multiple threads in process gpu-process.
(node:3145) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
[3098:3173:0501/002304.185315:ERROR:data_store_impl.cc(131)] Failed to open Data Reduction Proxy DB: 3
[3098:3173:0501/002304.195597:ERROR:database.cc(1584)] Shortcuts sqlite error 14, errno -2: unable to open database file, sql: – sqlite3_open()
[3098:3173:0501/002304.195705:ERROR:database.cc(1584)] Predictor sqlite error 14, errno -2: unable to open database file, sql: – sqlite3_open()

I am stuck, I tried removing and re install everything with no luck or change.

Thanks in advance

It looks like you have completely different issues. This is a problem with the database that cannot open. I recommend you to try to run it as root instead. If you don’t know how to do it, just tell me what did you downloaded (because there are several ways to install PT).

Thanks for your quick answer.

I followed these instructions:

I tried removing Popcorn and reinstall now…
I managed to run it with sudo ./Popcorn-Time from the opt/popcorntime directory, but it get stuck again in the loading page

I got the same problem before. Just go back into the desktop file you created and set ‘True’ to open in terminal and add sudo before the command. And everything should work excepted that you’ll need to write your password each time you want to launch PT . I don’t know how to solve that password problem.

You have a problem with the database here; You should try to run it as root. Depending on the way you installed it. If you use a Desktop file you can edit it and add ‘sudo’ before the command and change the value ‘open in terminal’ to True. If you don’t know how to do it, I can help you :smile:

Snowcode, if you can direct me a bit…Yes, I don’t know how to do it :grimacing:

Ok. I’ll try to guide you trough commands. So you can open the terminal and write:

sudo nano /usr/share/applications/popcorntime.desktop

Then you can replace the current content by:

[Desktop Entry]
Version = 1.0
Type = Application
Terminal = true
Name = Popcorn Time
Exec = sudo /usr/bin/Popcorn-Time
Icon = /opt/popcorntime/popcorn.png
Categories = Application;

Then when you start the launcher, it should prompt a terminal where you can write your password. Then PT should start properly.

Tell me if it works. :crossed_fingers:

Hi snowcode, thanks.
Unfortunately it did not work. I think I should try erase what I installed and re install everything: what is your opinion?
I went into the /usr/bin folder and can’t find any file named Popcorn-Time…

Thanks again for helping me learning a bit more about Ubuntu.

Ok so I think you forgot the step 3 of the given guide:

sudo ln -sf /opt/popcorntime/Popcorn-Time /usr/bin/Popcorn-Time

So that’s should move the file to get it into the /usr/bin folder.

1 Like

Thanks.
Here above is the message I’ve got.