Popcorn time "Watch now" button not loading

I went on to Popcorn Time today with the newest version on MAC and started watching the first episode of Ghost Hunters, and when that episode ended I tried to watch the second and the “Watch now” button didn’t work. I’ve uninstalled and reinstalled PT twice now and still not working, is this a server issue? Or is there something wrong with mine specifically?

It’s a bug … been reported before (still waiting for the fix!) You may come across other issues as well? You could try deleting the support/data folders and rebooting the app?

Delete these three Popcorn-Time (support) folders and the popcorn-time file from your user Library:
~/Library/Application Support/Popcorn-Time
~/Library/Cache/Popcorn-Time
~/Library/Saved Application State/com.nw-builder.popcorn-time.savedState
~/Library/Preferences/com.nw-builder.popcorn-time.plist

if you’ve done it correctly you should see “The Terms of Service” window when you reboot?

Or you could try the latest build from here: https://ci.popcorntime.app/view/All/ #423, I think!
(… and make it a clean install - delete those folders and file?)