Please update your README

Hi

the README is oudated. I.e. you mention ./make_popcorn.sh that is not even available in the repo.

Please give a clear install procedure for linux/ubuntu.
These commands

  1. yarn config set yarn-offline-mirror ./node_modules/
  2. yarn install --ignore-engines
  3. yarn build
  4. yarn start

don’t work (No gulpfile found).

Thanks

Yes I can relate that. I use Ubuntu as well have you already posted an issue or a pull request on the repo?

1 Like

@snowcode can you explain to me how to install it properly in Ubuntu ?
Thank you

I actually had a very weird way to install it. But It’s ok for me.

  1. Download the Linux version from the official website and unpack the archive
  2. You’ll have a file called ‘Popcorn-Time’, click right on the file and look in the permission if the case ‘Allow executing file as program is ticked’
  3. Use the software menu-libre to create a shortcut for Popcorntime. To do so, just put the following settings:

Just click on the launcher and write your password to start PT.

Tell me if it works for you!

Edit! I just found that the tarball don’t have the ./make-popcorn.sh but now it’s available on the repository of PY : https://github.com/popcorn-official/popcorn-desktop.
I cannot install it either for the moment because of this error:

npm ERR! code EINVALIDPACKAGENAME
npm ERR! Invalid package name "chromecast-api ": name cannot contain leading or trailing spaces; name can only contain URL-friendly characters

I will look at it.

Hi,
when I ./make_popcorn.sh I get prompted with

You appear to be inside of a Popcorn Time repository already, not cloning
Do you wish to install the required dependencies for Popcorn Time and setup for building? (yes/no) [yes]

Then, when installing the dependencies I get the following:

npm ERR! Linux 4.4.0-177-generic
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! node v4.2.6
npm ERR! npm  v3.5.2
npm ERR! code EMISSINGARG

npm ERR! typeerror Error: Missing required argument #1
npm ERR! typeerror     at andLogAndFinish (/usr/share/npm/lib/fetch-package-metadata.js:31:3)
npm ERR! typeerror     at fetchPackageMetadata (/usr/share/npm/lib/fetch-package-metadata.js:51:22)
npm ERR! typeerror     at resolveWithNewModule (/usr/share/npm/lib/install/deps.js:456:12)
npm ERR! typeerror     at /usr/share/npm/lib/install/deps.js:457:7
npm ERR! typeerror     at /usr/share/npm/node_modules/iferr/index.js:13:50
npm ERR! typeerror     at /usr/share/npm/lib/fetch-package-metadata.js:37:12
npm ERR! typeerror     at addRequestedAndFinish (/usr/share/npm/lib/fetch-package-metadata.js:82:5)
npm ERR! typeerror     at returnAndAddMetadata (/usr/share/npm/lib/fetch-package-metadata.js:117:7)
npm ERR! typeerror     at pickVersionFromRegistryDocument (/usr/share/npm/lib/fetch-package-metadata.js:134:20)
npm ERR! typeerror     at /usr/share/npm/node_modules/iferr/index.js:13:50
npm ERR! typeerror This is an error with npm itself. Please report this error at:
npm ERR! typeerror     <http://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR!     /home/louisro/popcorn-desktop/npm-debug.log

And, from the install file downloaded from the website, I unzip and went into the directory Popcorn-Time-0.4.4-linux64.
Then, chmod +x Popcorn-Time
Then $ ./Popcorn-Time gives

    [11898:11898:0426/132333.544208:ERROR:process_singleton_posix.cc(311)] Failed to create /home/louisro/.config/Popcorn-Time/SingletonLock: File exists (17)
    [11898:11898:0426/132333.544595:ERROR:chrome_browser_main.cc(1433)] Failed to create a ProcessSingleton for your profile directory. This means that running multiple instances would start multiple browser processes rather than opening a new window in the existing process. Aborting now to avoid profile corruption.

When using menulibre and creating a launcher, it doesn’t launch when I click on the launcher.

Any idea ?

Ubuntu 16.04

It’s normal, you need to tick the setting ‘run using terminal’.

Just one question. Do you want to use it for development or do you just want to use it to watch movies and series? Because I think that the ‘make_popcorn’ method is more to build everything from source AKA painful method. Maybe it’s a better idea to use the binaries and creating a launcher if needed? I don’t know I just propose.

BTW: Not very important but I use Ubuntu 18.04

Edit: Can you change the category to Desktop: Linux on your post?

I had to delete the previous profile directory in ~/.config/Popcorn-Time

Ok I ticked the “run in terminal” option in menulibre and it launches !

Indeed, I am just a “user” of Popcorn, not a developer.

I’d love to change this thread category, but I don’t know how ?

1 Like

You click on the edit icon on your post and then you can choose the category like this:

I don’t have an edit button for the first post.

Oh never mind so. I think the admin of the server has disabled it. The main point is that you solved your issue!

ok I see.

I installed Popcorn, but I have to type my password each time I launch it and I see errors in the terminal.
So no, the issue is not solved: I think the README still needs clean-install steps for Linux.

Do you think it can be done ?

There are errors in terminal but some are more like warnings and do not impact the usage of the software. I got a few too.
And yes the README needs to be updated but it’s a known issue:


But obviously it’s sad to see the lack of concern about these issues :frowning_face:
One of them is from one month ago and the other was the made the last year.

The best thing would be to find the issue and succeed to install build it but ourselves and make a pull request, I believe they would accept.

And for the password each time, maybe you can try without the ‘sudo’ inside the menulibre to edit the launcher. But for me I got a kind of infinite loading screen. Tell me what you have with it.
But first can you send me the output of your terminal when you launch the PT launcher?

I created another issue about this issue on GitHub

In case of they would notice it.

1 Like

Great initiative. Thanks!

1 Like

Yes because really, WHY did they dropped the support of the DEB file of 0.3.1 I don’t understand.

Yes I don’t know reallly.

1 Like

Well I think we distributed by creating one more issue, so I closed it and I noticed that there is a DEB package anyway inside the releases. I don’t know why they don’t mention it on the website and/or on the README.
Can you try it? For me it does not work properly and I have this issue: (but on Linux)

You can download the deb file from here:

I hope it will work for you!

BTW: Can you give me your top 5 things to change the README because I forked the repo to make PR.

I am trying to make an alternative deb file as I told you to do with menulibre. (it’s just a sudoed version of this: https://www.reddit.com/r/PopCornTime/comments/fnw6zz/im_trying_to_install_popcorntime_from_the_app/flcnsjw/ but in a deb file to be easier to install)

I don’t know if I can send it on this forum, so if you want to get it (after testing the original deb file) you can PM me on the forum.

I made the deb file using a tool called ‘debreate’

Hi @snowcode
I think the README needs a simple and clear procedure towards a clean install of PT.
And it also needs to differentiate clearly between the “dev” install and the “simple user” install.

Thanks !!

1 Like