New version doesn't work

Lately my popcorn time has not been working. Before I updated it, it worked but now there are problems all the time. Example when i’m trying to watch “FBI” or “Notorious” series, it doesn’t let me watch them. When I push the “watch” buttom, it stucks and shows me “Anyone can know where you’re wrong”… and shows on the bottom “downloading” that takes 6 hours and it doesn’t really download it and it can’t possibly take that long. The old version worked better so is there anyway I could fix this problem with the newest version that I now have, or where/how could I download/get the old version back?
(I have HP laptop & Windows 10 -version)

I can point you to a 0.3.10 build (they’re still available) and you can patch it with the new API update. But you’ll need to do a bit of work yourself, though? … Read through this post, see if your up for it?

Hi, thank you I will try that. I just don’t understand/find the first step to find “show package contents” from my popcorn time app.

I’m a Mac user …
liana and djdlr and a lot more judging by the download count seem to have figured it? You could ask them in private mail through messages if you get stuck?

I need to disappear for a bit … I’ll double-check with my PC friend and get back to you. There’s trouble with Reddit at the moment … it’s down: it says “You broke Reddit!” :laughing:

okay, I will try to find. I just don’t know where the menu is located, I can only find settings. I try to figure this out. Thank you for answering!

Do it on the downloaded app/package? You’e going to change an internal file in the app’s “programme?”

There is not an option for menu. I’ll try to send a message to those who you mentioned. Thank you!

Patch the Dev Win64 #279 build … it’s the most stable version and has some improvements over the basic version.

And as it says in the post … make it a clean install (if you can!). Otherwise your nice new version will share the same old support/data files … not recommended.

I did but it just keep rolling and it wont show any movies or series. Maybe it will work later. Thank you anyway.

You changed the index.js file?

I’m not sure what you mean but I tried to install it and it didn’t work, so I deleted everything and I tried second time but the same happened. I guess i’m just not gonna get it to work :confused:

You still have to apply the API patch (index.js file) … I’ve given you the 0.3.10 version: But it won’t work without the patch … Remember my first post?

I deleted everything related to popcorn time as you adviced and I installed the old version that you adviced me to. I will try the longer version that you first linked me if I get an answer from liana and if she can help me to find the menu on popcorn time.

Ok, found the location on Windows. C:\Users\YourUserNameHere\AppData\Local\Popcorn-Time\ … same place you’d delete the ‘User Data’ folder for a “clean” reboot?

So if you open: node_modules > > you should see 2 files … we’re going to swap the one called index.js.

Ok so far? Here’s the link for the replacement index.js file ( with the new API domain).
Just download the file and drag it into that window … it should say something like “do you want to replace or keep the older file” … obviously we want to replace it. Then just close everything up.
0.3.10 should now be updated?

On more thing:
When you open it - go to the PT ‘Settings’ window and untick the “activate auto updating” option … you might have to tick “show advanced options” at the top of the window first?

I got everything else except I can’t drag it to the window, I don’t know if i’m doing it wrong. They’re are both on my this PC > desktop but it does nothing when I try to move the new file to the popcorn time file.

Can you open the “old” index.js file we want to change with your Windows text editor?

no, it says something about module not being determined.

Not sure … there must be a different method to alter an apps package files in Windows … I’ll ask?

So much easier with a Mac!

Just checked on the subreddit … it should be as easy as Copy/Paste from one to the other. Here’s one of the mods comments:

The fix works, you probably edited something wrong. If you want to keep 0.3.10 you could just copy the entire right side (without the line numbers), delete everything in your \node_modules``\index.js and paste what you’ve copied. BUT, if you are happy with 0.4.4, keep that one.
(He sounds a bit angry!)

I can’t see what your doing (or duplicate it) … we’ll just have to call it a bust!

OMG it worked!!! Thank you soooooo much!!! really, you’re awesome. Now it works and i’m so happy! Thank you <3 ! :heart_eyes: :smiling_face_with_three_hearts: