Cannot use PopCorn after automatical Update, my IOS is not compatible

Hi, after Popcorn Time made update to last version (automatically always)
and request me to “restart” i cannot open again cos new version is not supported by my IOS or visceversa.
I deleted update and run old version (3) and works but after some minutes this happend again

I uncheck one tab about updates on Preference/ Miscellaneus but dont work an continue updating
automatically the app
Any Suggestions?

I run Macbook Pro 2009 with Mavericks
Thanx

I think you meant OS X?

OS X Mavericks 10.8 is supposed to be supported (according to the download page)?

Untitled

I think El Capitan would be better - you can still use PT 0.3.10 (if you want) … but you’ll need to do a clean install (delete support folders/file) and fix the API:


… and prevent the update (delete a file).

Hope you enjoy DIY! :smiley:

Ok I tried all this options. Deleted restarted, editing file. like reddit guide, etc
1-If i edit the file settings.js (on 3.10) after popcorn app crash and never open
2- if i restore settings.js to normal (on 3.10) app open but never charge movies
3- If i install 4.4 version installation is good but when i go to Applications the icon of Popcorn is in forbbiden mode (system cannot open version)
4- If i delete , restart and install again 3.10 now i also cannot watch nothing cos i have this message on screen:
“THE REMOTE SHOW API FAILED TO RESPOND, PLEASE CHECK http://status.popcorntime.sh AND TRY AGAIN LATER”

Any suggestions?
Danke

  1. You must have made a mistake … many of us are running 0.3.10 with the API patch? See below:

  1. At least it’s not auto-updating - you’ve got an original to play with?

  2. That’s just “Gatekeeper” … if your doing a one click to open, it won’t do it because it’s a “new” download?
    Open the Application folder in Finder window and right click (two-finger) on PT.app > choose open from the side menu?

  3. Refer back to number 1.

Hi
I make what tutorial on reddit explain
is not first time i open an app like a folder with “right click”…
i found folder and edit file settings.js adding “//” before the line
i delete updater .js, etc, i restart etc
When i add “//” app not open
When i restore normally settings app open but never charge the movies and give the message i copy before about API
I dont know is is “original” i really don’t remember when/ where i take this 0.3.10 but before 1 week before i use same to watch movies. The only problem like i explained before is that after some minutes and advice appears in right corner “update sucesfull, restart” or something like this
and like i said, my OSx dont let me open new version.
WHERE I CAN FOUND “ORIGINAL” 0.3.10 32 bit for mac for try again?

etc etc

Thanx

Can you post a screenshot of that … I’m curious?

One of the subreddit guys has linked some of the older (stable) builds (no longer on the GitHub) here: https://mega.nz/folder/20VBkaqK#yVC2H-yAKtc32hZgmCnUqw.
I prefer #293/279 for MacOS. Better than “original” … some improvements/updates were made.

If it keeps trying to update - don’t open the app until you’ve deleted the update.js file. Forget about add // … I don’t think it’s needed.
AND before doing anything … better if you delete the Popcorn-Time support folder as well (from here: ~/Library/Application Support/Popcorn-Time) … and make it a “clean” install/reboot?

I think that might be because you’re running Mavericks - it may be missing something 0.4.4 requires. nw.js update maybe?

If you get really stuck - I can PM you my patched copy (I know that works!)

1 Like

HI Mersey V
Im gonna try some of your suggestions, anothers i done before (delete all popcorn folders after uninstall) i even used Appzapper to unninstall but anyway i check after all folders and deleted manually if is needed.
Aclaration: I dont have way to stop the automaticall updated of the app, i repeat If i run (in past) 3.10 after i finish to watch my movie i discover this advice in corner inside popcorn time interface “update sucefull you must restart” (or something like that…) Not depends of me, this happends everytime even if i dont watch nothing, after i closed app this appears with the forbidden mark over icon (im sending this for your curiosity…not exactly with popcorn cos now i cannot open popcorn)
Of course you can send me your patch by PM

Captura de pantalla 2020-04-17 a la(s) 09.10.18

I guess i said before but i repeat
My mavericks is 32 bit
i download this links you share and all said Osx 64

Please tell me if in this folder from Mega i could found 3.10 32 bit Osx version
Thanx

Don’t like these uninstall apps myself … I do it manually.

3 folders and 1 file:
~/Library/Application Support/ Popcorn-Time
~/Library/Cache/ Popcorn-Time
~/Library/Saved Application State/ com.nw-builder.popcorn-time.savedState
~/Library/Preferences/ com.nw-builder.popcorn-time.plist

apart from deleting the old PT app - that’s it?

Mavericks OS is 64 bit? It runs 64 bit applications?
https://discussions.apple.com/thread/6466253

As far as I can remember Mac didn’t have a 32bit version … except for Linux. Here’s some old repo’s going back to 2015 (Popcorntime.io)
https://get.popcorntime.app/repo/build/

lol … doesn’t help me - don’t recognise it (never mind).

Then you haven’t deleted the update.js file before you opened the new PT download? (you are using a “fresh” copy?) … you must remove it (update.js file) before you open the copy of PT 0.3.10 … and delete the support files before booting the app - for a clean install?
One of us (or both) is missing something? … are you creating a new copy of 0.3.10 from a previous (archived) download of PT?

Hi dude, thanx again
Well i check all the folders you suggest me, i have all the files deleted by Appzapp but only one stay
~/Library/Saved Application State/ com.nw-builder.popcorn-time.savedState, finally i deleted manually but Did you really think this could be the problem?
Youre right about 64 bit, i confused cos i have one appl install 32bit (ableton live)and everytime i need to use 64 pluggins i cannot, but not because my system, is only cos my version of 32 bits.
Anyway, yes i deleted (or change name ) to update. js, even the patch when i copy deleted this alone.

Maybe is better try again from start:
Mavericks 10.9.5 Osx , 3.10 (without patch version) was working until 2 weeks before after use the app, i have one advice on interface “updated sucefully, you must restart” Next time i go folder apps, i see the icon of Popcorn app with this “forbidden " slash over it and cannot do nothing (i update picture of another app but same situation just for example cos i dont have more version 4 to show you).
To continue use 3,10 i used to deleted this new “forbiden” app icon, and unzip again my 3,10 so i cna use again and again but everytime must do same cos update run automatically.
One day after start to try solutions at this forum, app start to open BUT, not charge the movies or series in first screen (menu of movies) and gave me the message about problem with API go to page “www.etc” to see if we are online” or something like that.
After all of these i never can run again or use the app.
Hope this help in create featuring solution for my situation

I sent a copy of my API patched (not-updating!) build #293 of PT 0.3.10, to the dude using Mac Catalina. He said it works?

I’ll PM you a 24hr link to my copy - for testing on your set-up. Might work … might not!
Fingers crossed! … we’ll see?

1 Like

i see PM today, i was confused where im gonna receive your file.
Anyway maybe you can send again cos this expired.

Thanx man

No Prob … I’ll PM it to you. Just uploading it to Firefox send (won’t be long!)

Edit: there’s a possibility Mavericks OS is just too old … we’ll see what happens?